Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет количество четных отрицательных чисел. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введенные числа не превышают 30 000.
Программа должна вывести одно число: количество четных отрицательнх чисел
Пример работы программы
Входные данные
-17 2 -6 0
Выходные данные
1
С
- 06.04.2018 21:41
- Информатика
- remove_red_eye 2702
- thumb_up 37
Ответы и объяснения 1
#include
#include
int main()
{
setlocale(LC_ALL, "RUS");
int count = 0;
int n;
for (int i = 0; i < 1000; i++)
{
printf("Введите число >> ");
scanf("%d", &n);
if (n == 0)
break;
if (n % 2 == 0 && n < 0)
count++;
}
printf("%d", count);
}
- 07.04.2018 20:59
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.