Вопрос по информатике:
Дано четыре целых числа. Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные
Входные данные: с клвиатуры вводится 4 целых числа
Выходные данные: необходимо вывести на экран преобразованные числа в той же последовательности
Пример входных и выходных данных
Входные данные
3 5 -2 -4
Выходные данные
9 25 16 256
C++
- 24.12.2017 03:51
- Информатика
- remove_red_eye 5351
- thumb_up 17
Ответы и объяснения 1
#include "stdafx.h"
#include
#include
int main()
{
int arr[4];
for (int i = 0; i < 4; i++)
{
std::cin >> arr[i];
if (arr[i] > 0)
arr[i] = pow(arr[i], 2);
else
arr[i] = pow(arr[i], 4);
}
for (int i = 0; i < 4; i++)
std::cout << arr[i]<<" ";
std::cout << "\n";
system("pause");
return 0;
}
- 25.12.2017 09:09
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.