Вопрос по информатике:
Задача «Разность времен»
Условие
Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени.
Программа на вход получает три целых числа: часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени.
Выведите число секунд между этими моментами времени.
НА ПИТОНЕ ВЕРССИ 3
- 10.04.2018 13:46
- Информатика
- remove_red_eye 5995
- thumb_up 29
Ответы и объяснения 1
program vrem;
var
s1,s2,m1,m2,h1,h2,sec:integer;
begin
write('Perviy moment: ');
readln(h1,m1,s1);
write('Vtoroy moment: ');
readln(h2,m2,s2);
sec:=(s2-s1)+(((m2-m1)+((h2 - h1)*60))*60);
writeln('Sek: ',sec);
readln;
end.
- 11.04.2018 21:27
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.