Вопрос по информатике:
Помогите пожалуйста!Программы в Паскале.
1)Напишите программу,которая находит сумму,произведение и среднее арифметическое трёх целых чисел,введенных с клавиатуры.Примеры:4+5+7=16;4*5*7=140;(4+5+7)/3=5.333.
2)Напишите программу,которая вводит радиус и вычисляет его площадь и длину окружности.Примеры:радиус 5;площ. и длин.окр. 78.540,31.416
3)Напишите программу,которая вводит два целых числа,а и b(а<b),и выводит через пробел 5 случайных целых чисел на отрезке[а,b].Примеры:входные дан.0 100
выходные дан.0 3 86 20 27
- 23.09.2018 00:57
- Информатика
- remove_red_eye 17182
- thumb_up 45
Ответы и объяснения 1
var a,b,c:integer;
begin
readln(a,b,c);
writeln(a,'+',b,'+',c,' = ',a+b+c);
writeln(a,'*',b,'*',c,' = ',a*b*c);
writeln('(',a,'+',b,'+',c,')/3 = ',(a+b+c)/3:5:3);
end.
Пример:
4 5 7
4+5+7 = 16
4*5*7 = 140
(4+5+7)/3 = 5.333
2)
var r:integer;
begin
readln(r);
writeln('S = ',pi*r*r:5:3);
writeln('C = ',2*pi*r:5:3);
end.
Пример:
5
S = 78.540
C = 31.416
3)
var a,b,i:integer;
begin
readln(a,b);
for i:=1 to 5 do
write(random(b-a+1)+a,' ');
end.
Пример:
0 100
8 1 86 54 60
- 23.09.2018 07:25
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.