Вопрос по информатике:
Free pascal. Написать программу детектирования слова-полиндрома
- 23.11.2017 02:28
- Информатика
- remove_red_eye 10773
- thumb_up 24
Ответы и объяснения 1
begin
readln(st);
l:=length(st);
b:=true;
for i:=1 to l div 2 do
if st[i]st[l-i+1] then b:=false;
if b then writeln('Слово - палиндром')
else writeln('Слово - не палиндром');
end.
Пример:
казак
Слово - палиндром
- 24.11.2017 16:50
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.