Вопрос по информатике:
1. Составить программу вычисления S=1/2+1/4+1/8+…+1/128.
2. Задан массив. Составить программу которая вводит с клавиатуры 10 чисел и выводит их в обратном порядке.
ТУРБО ПАСКАЛЬ, ПОЖАЛУЙСТА
- 21.06.2016 23:35
- Информатика
- remove_red_eye 8042
- thumb_up 29
Ответы и объяснения 1
Задание 1).
Program Summ_S;
var
I, N, DENOMINATOR: integer;
S, SUMM: real;
begin
N:=1;
for I:=1 to 999 do begin
if DENOMINATOR=128 then begin
write('S = '+SUMM);
break;
end;
DENOMINATOR:=N*2;
S:=1/DENOMINATOR; // 1/1*2, 1/2*2, 1/4*2...
N:=DENOMINATOR;
SUMM:=SUMM+S;
end;
end.
Задание 2).
Program Massive;
var
num_1, num_2, num_3, num_4, num_5,
num_6, num_7, num_8, num_9, num_10,
number: longint;
i: integer;
begin
for i:=1 to 10 do begin
write('Введите число: ');
readln(number);
case i of
1:num_1:=number;
2:num_2:=number;
3:num_3:=number;
4:num_4:=number;
5:num_5:=number;
6:num_6:=number;
7:num_7:=number;
8:num_8:=number;
9:num_9:=number;
10:num_10:=number;
end;
end;
writeln('Введенные числа в обратном порядке: '
+num_10,num_9,num_8,num_7,num_6,
num_5,num_4,num_3,num_2,num_1);
end.
P.S Можно и по другому сделать, но я уже паскаль особо не помню.
Надеюсь помог, удачи :)
- 22.06.2016 02:07
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.