Вопрос по информатике:
Школа Чародейства и Волшебства «Хогвардс» делится на четыре факультета: Гриффиндор, Пуффендуй, Когтевран и Слизерин. В конце учебного года каждому факультету начисляется определенное количество баллов. Факультет, набравший наибольшее количество баллов, выигрывает кубок школы. За нарушение дисциплины Гарри Поттером факультет Грифиндор потерял N баллов, а за победу над Квирреллом Гарри вместе с друзьями принес факультету M баллов. Определите, сможет ли факультет Гриффиндор выиграть кубок школы.Формат входных данных:Первая строка содержит четыре числа – исходные баллы факультетов в порядке: Гриффиндор, Пуффендуй, Когтевран и Слизерин.Во второй строке числа N и M. Все числа натуральные и не превосходят 10000.Формат выходных данных:Вывести единственное слово 'yes', если победил факультет Гриффиндор, и 'no' в противном случае.
- 13.12.2017 17:25
- Информатика
- remove_red_eye 8111
- thumb_up 13
Ответы и объяснения 1
var Gr, Pu, Ko, Sl,n ,m : integer;
begin readln(Gr, Pu, Ko, Sl); readln(n, m); Gr := Gr - n + m; if (Gr >= Pu) and (Gr >= Ko) and (Gr >= Sl) then writeln('Yes') else writeln('No')end.
- 14.12.2017 04:51
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.