Вопрос по информатике:
Напишите программу, которая в массиве из 30 натуральных чисел определяет количество чисел, оканчивающихся на 8. В массиве всегда имеется число, оканчивающееся на 8.
- 04.03.2017 17:00
- Информатика
- remove_red_eye 1404
- thumb_up 41
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(30,1,20); a.Println;
Writeln('Элементов, оканчивающихся цифрой 8- ',
a.Where(x->x mod 10=8).Count)
end.
Пример
1 3 20 17 2 5 3 14 18 1 13 3 8 9 5 19 19 3 19 20 2 12 20 13 7 5 10 9 1 20
Элементов, оканчивающихся цифрой 8- 2
- 05.03.2017 09:49
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.