Вопрос по информатике:
Дан текст, содержащий не более 10 слов, из строчных русских букв, между соседними словами – запятая, за последним словом - точка. Составить программу, в которой нужно напечатать в алфавитном порядке все гласные буквы, которые входят хотя бы в одно слово более двух раз.
написать на паскале и функций не нужно
- 02.02.2018 09:12
- Информатика
- remove_red_eye 5310
- thumb_up 25
Ответы и объяснения 1
begin s:='которой,нужно,напечатать,алфавитном,порядке,все,гласные,буквы,которые.'; {readln(s);} {инициализация массива счётчика гласных} for k:=1 to length(rchars) do mas[k]:=0; i:=1; while i<=length(s) do begin {проверка на соответствие буквы гласной, согласно списку гласных} for k:=1 to length(rchars) do if (rchars[k]=s[i]) and (mas[k]-1) then mas[k]:=mas[k]+1; if (s[i]=',') or (s[i]='.') then begin
{проверить повторение гласных на два и более раз и проинициализировать массив счётчик} for k:=1 to length(rchars) do if (mas[k]<=2) and (mas[k]-1) then mas[k]:=0 else mas[k]:=-1; end; Inc(i); end;
{Вывод повторяющихся гласных}
s:=''; for k:=1 to length(rchars) do if mas[k]=-1 then s:=s+rchars[k];
writeln(s);end.
- 03.02.2018 12:43
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.