Вопрос по информатике:
// Решение нужно на языке программирования C++.
Задан номер мобильного телефона. Определить, какие цифры отсутствуют в этом номере.
Входные данные: в единственной строке задан номер мобильного телефона.
Выходные данные: в первой строке вывести количество отсутствующих в номере цифр. Во второй строке в порядке возрастания вывести отсутствующие цифры, разделенные пробелом.
- 05.03.2017 07:27
- Информатика
- remove_red_eye 8341
- thumb_up 38
Ответы и объяснения 1
#include
#include
using namespace std;
int main()
{
string s;
cin >> s;
set mySet;
set::iterator it;
for(char i='0'; i<='9'; i++) mySet.insert(i);
for(int i=0; i
for(it=mySet.begin(); it!=mySet.end(); ++it)
cout<<*it<<" ";
return 0;
}
Пример:
74959741926
3
0 3 8
- 06.03.2017 07:00
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.