Вопрос по информатике:
1) Задано натуральное число N. Составить программу для вычисления факториала N.
2) Подсчитать количество четных отрицательных элементов в матрице размером МхN, элементы которой вводятся с клавиатуры.
- 22.08.2017 12:59
- Информатика
- remove_red_eye 15940
- thumb_up 39
Ответы и объяснения 1
using namespace std;
long Factorial(int num)
{
long res = 1;
for (int i = num; i > 1; i--)
res *= i;
return res;
}
int NumOfElements(int **matrix, int mSize, int nSize)
{
int res = 0;
for (int i = 0; i < mSize; i++)
{
for (int j = 0; j < nSize; j++)
if (matrix[i][j] % 2 == 0 && matrix[i][j] < 0)
res++;
}
return res;
}
int main()
{
int
num,
**matrix,
mSize,
nSize;
cout << "Input a number: ";
cin >> num;
cout << num << "! = " << Factorial(num) << endl;
cout << "Input a matrix size: ";
cin >> mSize >> nSize;
matrix = new int*[mSize];
for (int i = 0; i < mSize; i++)
matrix[i] = new int[nSize];
for (int i = 0; i < mSize; i++)
for (int j = 0; j < nSize; j++)
cin >> matrix[i][j];
cout << "Num. of the elements = " << NumOfElements(matrix, mSize, nSize) << endl;
system("pause");
return 0;
} /* End of the 'main' function */
- 23.08.2017 06:56
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.