Вопрос по информатике:
Помогите! Язык Си
Написать программу,которая находит количество простых членов последовательности.
- 18.09.2015 02:42
- Информатика
- remove_red_eye 15074
- thumb_up 22
Ответы и объяснения 1
#include
using namespace std;
int main()
{
setlocale(LC_ALL,"RUS");
int N;
cout <> N;
cout <<"Введите сами числа: ";
int k = 0;
for(int i = 0; i < N; i++)
{
int A;
cin >> A;
if (A > 3)
{
int B = 1, K = sqrt(A), d = 2;
while(d <= K)
{
if (A % d++ == 0)
{
B = 0;
break;
}
}
if (B) k++;
}
else if (A > 1) k++;
}
cout <<"Количество простых, среди введённых: "<
}
- 19.09.2015 19:36
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.