Вопрос по информатике:
Написать программу на языке Паскаль, реализующую следующую задачу: Продаются товары двух видов. Запросить с клавиатуры для каждого товара цену, количество в начале рабочего дня и количество проданного товара (и одного и другого) за день. Вывести выручку от продажи двух товаров за день.
- 16.02.2015 22:46
- Информатика
- remove_red_eye 11084
- thumb_up 45
Ответы и объяснения 1
Запрашивается количество проданного товара.
Выводится ответ.
Возможно, надо было запросить не кол-во проданного товара, а кол-во оставшегося товара, но я составил программу по условию. (если нужна будет другая, то отредактирую)
program tovar;
var t1,t2,p1,p2:integer;
c1,c2,s:real;
Begin
WriteLn('Сколько товаров первого вида было в начале рабочего дня?');
ReadLn(t1);
WriteLn('Цена товаров первого вида?');
ReadLn(c1);
WriteLn('Сколько товаров второго вида было в начале рабочего дня?');
ReadLn(t2);
WriteLn('Цена товаров второго вида?');
ReadLn(c2);
WriteLn('сколько товаров перового вида было продано за день?');
ReadLn(p1);
WriteLn('сколько товаров второго вида было продано за день?');
ReadLn(p2);
s:=p1*c1+p2*c2;
WriteLn('Выручка за день ' ,s);
end.
/// Возник вопрос. Зачем спрашивать, сколько товаров было в начале рабочего дня, если эти данные не используются, вот я и решил составить программу, которая, возможно, требовалась
program tovar;
var t1,t2,p1,p2:integer;
c1,c2,s:real;
Begin
WriteLn('Сколько товаров первого вида было в начале рабочего дня?');
ReadLn(t1);
WriteLn('Цена товаров первого вида?');
ReadLn(c1);
WriteLn('Сколько товаров второго вида было в начале рабочего дня?');
ReadLn(t2);
WriteLn('Цена товаров второго вида?');
ReadLn(c2);
WriteLn('сколько товаров перового вида осталось?');
ReadLn(p1);
WriteLn('сколько товаров второго вида осталось?');
ReadLn(p2);
s:=(t1-p1)*c1+(t2-p2)*c2;
if (t1-p1<0) or (t2-p2<0) then WriteLn('Внимание! Кол-во оставшихся товаров, больше чем кол-во товаров в начале рабочего дня. Проверьте правильность данных.');
WriteLn('Выручка за день ' ,s);
end.
- 17.02.2015 21:51
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.