Вопрос по информатике:
Петя играет с разноцветными кубиками. У него есть x красных, y зеленых и z синих кубиков. Он ставит кубики в ряд один за другим так, чтобы цвета соседних кубиков не совпадали. Какое максимальное количество кубиков можно поставить в ряд, с учетом этого условия?
Написать программу в паскале.
Заранее спасибо.
- 04.12.2017 11:13
- Информатика
- remove_red_eye 13689
- thumb_up 46
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger('Кол-во красных, зеленых и синих кубиков:',3);
a.Sort;
var k:=a[0]*3; a[1]-=a[0]; a[2]-=a[0]; // тройки
if a[1]>0 then begin
k+=a[1]*2; a[2]-=a[1]; // пары
end;
if a[2]>0 then k+=1; // последний
Writeln('Максимальное количество в ряду равно ',k)
end.
Пример
Кол-во красных, зеленых и синих кубиков: 8 2 5
Максимальное количество в ряду равно 13
- 05.12.2017 04:23
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.