Вопрос по информатике:
Составить программу - тест, которая запрашивает имя и предлагает ответить на три вопроса. Отвечать можно "да" или "нет". при вводе другого ответа - возврат к вопросу. в итоге программа выдает количество верных ответо
- 02.12.2017 08:48
- Информатика
- remove_red_eye 4925
- thumb_up 8
Ответы и объяснения 1
O:string;
i,k:byte;
B,pO:array[1..3] of string;
Begin
B[1]:='2 * 2 = 5 ?';pO[1]:='нет';
B[2]:='Оператор Read вводит данные?';pO[2]:='да';
B[3]:='СССР победил в войне 1812 года?';pO[3]:='нет';
k:=0;
For i:= 1 to 3 do
Begin
WriteLn(B[i]);
ReadLn(O);
O:=LowerCase(O);
While (O 'да')and(O 'нет') do
Begin
Write('Попробуйте ещё раз: ');ReadLn(O);
O:=LowerCase(O);
End;
if pO[i] = O then k:=k+1;
End;
WriteLn('Количество правильных ответов: ',k);
End.
- 03.12.2017 17:49
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.