Вопрос по информатике:
Разработать подпрограмму для вычисления суммы двух комплексных чисел использовать разработанную подпрограмму для вычисления суммы N комплексных чисел. значение N вводится с клавиатуры.
Помогите решить!
- 09.11.2017 14:13
- Информатика
- remove_red_eye 19999
- thumb_up 50
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
function ReadComplex:Complex;
begin
var (r,i):=ReadReal2;
Result:=cplx(r,i)
end;
procedure WriteComplex(x:Complex);
begin
if x.Imaginary=0 then Write(x.Real)
else begin
if x.Real0 then Write(x.Real);
if (x.Imaginary>0) and (x.Real0) then Write('+');
Write(x.Imaginary,'i')
end
end;
begin
var n:=ReadInteger('N =');
Writeln('Введите ',n,' комплексных чисел');
Writeln('Формат ввода числа: действ.часть, пробел, мнимая часть');
var s:=cplx(0.0,0.0);
loop n do s+=ReadComplex;
Write('S='); WriteComplex(s)
end.
Пример
N = 5
Введите 5 комплексных чисел
Формат ввода числа: действ.часть, пробел, мнимая часть
2.3 -3.12
-1.7 8
6.14 0.2
-2.4 -3.2
0 1.6
S=4.34+3.48i
- 01.01.1970 00:00
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.