Вопрос по информатике:
Написать программу на СИ...... Среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.
- 16.07.2018 11:16
- Информатика
- remove_red_eye 12321
- thumb_up 48
Ответы и объяснения 2
int main(void) {
double x,y,z;
int a,b,c;
printf("x = ");
scanf("%lf", &x);
x = x*10;
y = modf(x,&z);
a = (int)z%10;
x = x*10;
y = modf(x,&z);
b = (int)z%10;
x = x*10;
y = modf(x,&z);
c = (int)z%10;
if (a*b*c == 0) printf("Yes");
else printf("No");
return 0;
}
Пример:
x = 3.40249
Yes
- 17.07.2018 10:53
- thumb_up 27
#include
#include
#include
int main()
{
setlocale(LC_ALL, "RUSSIAN");
float a;
int b;
bool flag=false;
char str[20];
printf("Введите число >> ");
scanf("%f", &a);
b = a;
float c = a - b;
sprintf(str, "%5.3f", c);
printf("Дробная часть: %s", str);
for (int i = 2; i < 5; i++)
{
if (str[i] == '0')
flag = true;
}
if (flag == true)
printf("\nПервые три цифры дробной части содержат цифру 0");
else
printf("\nПервые три цифры дробной части не содержат цифру 0");
printf("\n ");
system("pause");
}
- 18.07.2018 15:58
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.