Вопрос по информатике:
Помогите пожалуйста написать программу в Паскале. Дано натуральное семизначное число Р. Вывести на экран цифры чила, которые делятся на а без остатка. Определить кол-во цифр, удовлетворяющих этому условию.
- 04.10.2017 06:40
- Информатика
- remove_red_eye 18552
- thumb_up 42
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
Write('Введите Р и а: ');
var (P,a):=ReadInteger2;
var k:=0;
while P>0 do begin
var d:=P mod 10;
if d mod a=0 then begin Print(d); k+=1 end;
P:=P div 10
end;
Writeln(Newline,'Искомых чисел: ',k)
end.
Пример
Введите Р и а: 7568450 5
0 5 5
Искомых чисел: 3
- 05.10.2017 19:41
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.