Вопрос по информатике:
Составьте программу формирования и вывода на экран одномерного массива , состоящего из количества положительных элементов строк двумерного массива.
- 03.07.2017 13:13
- Информатика
- remove_red_eye 13132
- thumb_up 38
Ответы и объяснения 1
Const
N = 3;
M = 4;
Var
A:array[1..N,1..M] of shortint;
B:array[1..N] of byte;
i,j,k:byte;
Begin
Randomize;
For i:= 1 to N do
Begin
k:=0;
For j:= 1 to M do
Begin
A[i,j]:=random(21)-10;
Write(A[i,j]:3,' ');
if A[i,j] > 0 then k:=k+1;
End;
B[i]:=k;
WriteLn;
End;
WriteLn;
For i:= 1 to N do
Write(B[i],' ')
End.
- 04.07.2017 04:22
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.