Вопрос по информатике:
Паскаль ABC.Net
Дан произвольный текст на русском языке. Написать программу, которая
выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
Пожалуйста,с комментариями где можно
- 27.08.2017 13:28
- Информатика
- remove_red_eye 14637
- thumb_up 32
Ответы и объяснения 2
Text,S:string;
n,k:boolean;
i:integer;
Begin
Write('Введите текст на русском языке: ');ReadLn(Text);
Text:=LowerCase(Text)+' '; // перевоит текст в нижний регистр
WriteLn(Text); // показывает действие предыдущей строки
For i:= 1 to Length(Text) do
Begin
if ('а' <= Text[i])and(Text[i] <= 'я')or(Text[i] = 'ё') then S:=S+Text[i] // записываем русские буквы в S
else // как только встречаем другой символ, проверяем,
if Length(S) > 0 then // есть ли в S хоть одна буква,
Begin // и если есть, то проверяем условие задачки, и выводим слово на экран, если оно истинно
if (S[1] in 'бвгджзйклмнпрстфхцчшщ')and(S[Length(S)] in 'аоэиуыеёюя') then WriteLn(S);
S:=''; // далее обнуляем S
End;
End;
End.
Пример работы программы:
Введите текст на русском языке: Дан произвольный текст на русском языке. Написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
дан произвольный текст на русском языке. написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
на
программу
которая
слова
начинающиеся
на
согласную
заканчивающиеся
- 28.08.2017 23:33
- thumb_up 16
// Внимание! Если программа не работает, обновите версию!
begin
var pic:='\b[бвгджзйклмнпрстфхцчшщъь]\S*[аеёиоуыэюя]\b';
ReadlnString('Введите:').MatchValues(pic,RegexOptions.IgnoreCase)
.Println(NewLine)
end.
Пример
Введите: А роза упала на лапу Азора, а Карл у Клары украл кораллы.
роза
на
лапу
Клары
кораллы
- 29.08.2017 13:45
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.