Вопрос по информатике:
Помогите написать программу на паскале. Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную. Составьте программу определения индексов минимального элемента этого массива. Полученный результат вывести на экран.
- 23.10.2017 16:23
- Информатика
- remove_red_eye 9536
- thumb_up 52
Ответы и объяснения 2
n=5;
var
a: array[1..n,1..n] of integer;
i,j,im,jm: integer;
begin
writeln('Массив:');
for i:=1 to n do
begin
for j:=1 to n do
begin
read(a[i,j]);
end;
end;
writeln;
im:=1; jm:=1;
for i:=1 to n do
for j:=1 to n do
if a[i,j]begin
im:=i;
jm:=j;
end;
writeln('Минимум = ',a[im,jm]);
writeln('Строка: ',im,' столбец: ',jm);
readln;
end.
- 24.10.2017 02:00
- thumb_up 37
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Введите 25 целочисленных элементов массива');
var a:=ReadMatrInteger(5,5);
var t:=a.ElementsWithIndexes.MinBy(x->x[2]);
Writeln('Min=A[',t[0]+1,',',t[1]+1,']=',t[2])
end.
Пример
Введите 25 целочисленных элементов массива
-32 75 16 1 52
26 -41 -96 -67 79
-20 27 -38 -42 -92
-8 -1 30 -76 -56
95 -95 -11 20 70
Min=A[2,3]=-96
- 25.10.2017 22:24
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.