Вопрос по информатике:
Срочно очень Прошу. Написать программу в Паскале:
Надо заполнить массив случайными числами в диапазоне от 25 до 50, найти сумму четных чисел и их количество.
- 24.01.2018 01:21
- Информатика
- remove_red_eye 4216
- thumb_up 10
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),25,50); a.Println;
var s:=a.Where(x->x.IsEven);
Writeln('Четных чисел- ',s.Count,', их сумма равна ',s.Sum)
end.
Пример
n= 17
47 35 50 48 27 49 34 41 44 25 37 31 35 31 41 50 32
Четных чисел- 6, их сумма равна 258
- 25.01.2018 12:37
- thumb_up 37
var a := arrrandom(readinteger('Введите размер массива:'), 25, 50).println;
writeln('Кол-во четных чисел:', a.where(x -> x mod 2 = 0).count);
writeln('Сумма четных чисел:', a.where(x -> x mod 2 = 0).sum);
end.
- 26.01.2018 19:46
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.