Вопрос по информатике:
Составить программу нахождения цифр числа, состоящих на нечётных позициях (Dev-C++)
- 09.04.2018 18:47
- Информатика
- remove_red_eye 1940
- thumb_up 47
Ответы и объяснения 1
#include
using namespace std;
int main()
{
setlocale(LC_ALL,"Rus");
long long int A;
cout <> A;
if (A < 0) A = -A;
int i = 0;
while (A > 0)
{
if (i++ % 2 != 0) cout << A % 10 << " ";
A /= 10;
}
return 0;
}
Предполагается, что нумерация начинается права, с нулевой позиции.
Чтобы изменить номер начальной позиции, например, на единицу, нужно изменить десятую строку на int i = 1;
- 01.01.1970 00:00
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.