Вопрос по информатике:
Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два поля: year – для хранения года и month – для месяца. Пользователь вводит год и месяц. 8 Оператор выбора case по номеру месяца определяет количество дней в нем. Ситуация осложняется тем, что в феврале может быть как 28 дней, так и 29 (в високосный год). Год является високосным, если делится без остатка на 4 и при этом не является последним годом столетия, за исключением того столетия, которое без остатка делится на 400.
- 18.05.2018 04:10
- Информатика
- remove_red_eye 19629
- thumb_up 33
Ответы и объяснения 1
data = record
year:integer;
month:byte;
End;
Var
d:data;
Begin
Write('Год: ');ReadLn(d.year);
Write('Месяц: ');ReadLn(d.month);
Write('Количество дней в этом месяце: ');
Case d.month of
1,3,5,7,8,10,12:WriteLn(31);
4,6,9,11:WriteLn(30);
2:if (d.year mod 4 = 0)and((d.year mod 100 0)or(d.year mod 400 = 0)) then WriteLn(29)
else WriteLn(28)
End;
End.
- 19.05.2018 23:25
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.