Вопрос по информатике:
Написать программу на языке С(Си) Пусть процедура Socr (a,b,p,q) от целых параметров (b≠0) приводит дробь a/b к несократимому виду p/q. Описать данную процедуру и использовать её для приведения дроби 1+1/2+1/3+...+1/20 к несократимому виду c/d.
- 22.09.2015 01:26
- Информатика
- remove_red_eye 1994
- thumb_up 9
Ответы и объяснения 1
#include
int Socr(long long int a, long long int b, long long int *p, long long int *q)
{
long long int d;
int c = 0;
if (a)
{
if((float)a/b<0)
{
if(a<0) a=-a;
if(b<0) b=-b;
c = 1;
}
for(d = (a>b?b:a); (a%d!=0||b%d!=0); d--);
if (c) *p = -a / d;
else *p = a / d;
*q = b / d;
}
else
{
*p = 0;
*q = 1;
}
return 0;
}
int main(int argc, char *argv[])
{
long long int a = 1, b, p = 1, q = 1;
for(b = 2; b < 21; b++)
{
printf("%lli/%lli + 1/%d = ",p,q,b);
Socr(p*b+q,q*b,&p,&q);
printf("%lli/%lli\n",p,q);
}
getch();
}
- 23.09.2015 14:10
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.