Вопрос по информатике:
(Паскаль) Дан текстовый файл, содержащий вещественные числа (положительные и отрицательные) в произвольном порядке. Сформируйте массив, содержащий только положительные числа из файла, и найдите наименьшее среди них.
- 24.04.2017 07:15
- Информатика
- remove_red_eye 11105
- thumb_up 47
Ответы и объяснения 1
var f:text;
i, n, count:integer;
l:string;
arr:array of real;
answ:real;
begin
assign(f, 'C:\Users\HO4HOU_TTaPKuPucT\Desktop\test_file.txt'); // В кавычках путь к файлу
reset(f);
while not eof(f) do begin
readln(f, l);
if StrToFloat(l) > 0 then
Inc(count);
end;
SetLength(arr, count);
reset(f);
i:=0;
while not eof(f) do begin
readln(f, l);
if StrToFloat(l) > 0 then begin
arr[i]:=StrToFloat(l);
Inc(i);
end;
end;
answ:=arr[0];
for i:=1 to arr.Length - 1 do
if arr[i] < answ then answ:=arr[i];
writeln(answ);
close(f);
end.
P.S. Программа работает с неограниченным числом положительных чисел в файле
- 25.04.2017 06:02
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.