Вопрос по информатике:
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них.
2. Составьте программу в Pascal ABC. Для данного вещественного x найти значение следующей функции f, принимающей вещественные значения:f(x)=(2-х)/x2,если x>0, иначе f(x)=6-х3
3. Составьте программу в Pascal ABC. Даны два числа. Найти их сумму, разность и произведение.
- 15.11.2015 22:47
- Информатика
- remove_red_eye 7117
- thumb_up 34
Ответы и объяснения 1
var a, b, c: integer;
begin
write('Введите через пробел три числа: ');
readln(a, b, c);
if (a > b) then
if (b > c) then
write('Сумма двух наибольших чисел: ', a + b)
else
write('Сумма двух наибольших чисел: ', a + c)
else
if (c > a) then
write('Сумма двух наибольших чисел: ', c + b)
else
write('Сумма двух наибольших чисел: ', b + a)
end.
2 задача.
var x, f: real;
begin
write('Введите значение x: ');
readln(x);
if (x > 0) then
f := (2 - x) / (x * x)
else
f := 6 - (x * x * x);
writeln('Значение функции при данном x: ', f)
end.
3 задача.
var a, b: integer;
write('Введите через пробел два числа: ');
readln(a, b);
writeln('Сумма чисел: ', a + b);
writeln('Разность чисел: ', a - b);
writeln('Произведение чисел: ', a * b)
end.
- 16.11.2015 05:36
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.