Вопрос по информатике:
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет.
2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр.
3. Составьте программу в Pascal ABC. Дано двузначное число. Вывести число, полученное при перестановке цифр.
- 02.01.2018 21:47
- Информатика
- remove_red_eye 7934
- thumb_up 48
Ответы и объяснения 1
var a: real;
x,y: integer;
begin
readln(x,a,y);
writeln('1 kg konfet stoit ', a/x:1:2);
writeln(y,' kg konfet stoyat ', a/x*y:1:2);
readln;
end.
2.
var a,s,p: integer;
begin
readln(a);
s:=a mod 10 + a div 10;
p:=(a mod 10)*(a div 10);
writeln(s);
writeln(p);
readln;
end.
3.
var a,b: integer;
begin
readln(a);
b:=(a mod 10)*10+(a div 10);
writeln(b);
readln;
end.
Это если без циклов.
- 03.01.2018 08:34
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.