Вопрос по информатике:
Помогите написать программу в С#.
В массиве А=(а1,а2,...,аn) удалить последнюю группу положительных элементов. Группой называется подряд идущие элементы одного знака, число которых больше или равно 2.
- 04.04.2018 22:00
- Информатика
- remove_red_eye 17087
- thumb_up 5
Ответы и объяснения 1
namespace СиШарп
{
class Program
{
static void Main(string[] args)
{
Console.Write("N = ");
int N = int.Parse(Console.ReadLine());
Console.Write("A({0}):",N);
int[] A = new int[N];
Random RND = new Random();
for (int i = 0; i < N; i++)
{
A[i] = RND.Next(-N,N+1);
Console.Write(" {0}",A[i]);
}
for (int i = N - 1; i >= 0 && A[i] < 0; i--) ;
int L = 0, j = N;
while (j > 0)
if (A[--j] > 0) L++;
else
if (L < 2) L = 0;
else break;
for(int i = j + L + 1; i < N; i++)
A[i - L] = A[i];
Console.Write("\nA({0}):",N-L);
for (int i = 0; i < N - L; i++)
Console.Write(" {0}",A[i]);
Console.ReadKey();
}
}
}
- 05.04.2018 04:29
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.