Вопрос по информатике:
Дано трехзначное число. Напишите программу, которая определяет:
является ли число "перевертышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.
122 - нет
121 - перевертыш
222 - перевертыш
- 04.07.2018 15:00
- Информатика
- remove_red_eye 4622
- thumb_up 31
Ответы и объяснения 2
if (a % 10 == a / 100) cout << "yes"; else cout << "no"; C
if a mod 10 = a div 100 then writeln('yes') else writeln('no'); Pascal
- 05.07.2018 02:28
- thumb_up 16
A:integer;
Begin
Write('Введите трёхзначное число: ');ReadLn(A);
if A div 100 = A mod 10 then WriteLn(A,' - перевёртыш')
else WriteLn(A,' - нет')
End.
- 06.07.2018 10:56
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.