Вопрос по информатике:
Даны две строки. Вычеркнуть из строки A символы,не встречающиеся в строке B.
Помогите написать программу для delphi или pascal.
- 01.07.2017 03:43
- Информатика
- remove_red_eye 19183
- thumb_up 40
Ответы и объяснения 1
begin
write('a: ');
readln(a);
write('b: ');
readln(b);
for i:=length(a) downto 1 do
if pos(a[i],b)=0 then delete(a,i,1);
writeln(a);
end.
Пример:
a: primer
b: write
rier
- 02.07.2017 01:40
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.