Вопрос по информатике:
Найти все двузначные числа, сумма цифр которых не меняется при умножении числа на 2,3,4,5,6,7,8,9.
написать программу на СИ
- 21.10.2017 07:45
- Информатика
- remove_red_eye 14792
- thumb_up 44
Ответы и объяснения 1
#include
int main(int argc, char *argv[])
{
int i, j, A, S;
for(i = 10; i < 100; i++)
{
S = i / 10 + i % 10;
for(j = 2; j < 10; j++)
{
A = i*j;
if (A / 100 +(A / 10) % 10 + A % 10 != S) A = 0;
}
if (A)! printf("%d ",i);
}
getch();
}
- 22.10.2017 06:27
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.