Вопрос по информатике:
Помогите составить программу на языке паскаль:
Вычислить значение выражения: f(x)=ctg 3x*log(2x+3)*4 при любых значениях х.
Прошу 16 баллов!
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 14.05.2015 10:57
- Информатика
- remove_red_eye 16867
- thumb_up 9
Ответы и объяснения 1
Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Нельзя вычислить логарифм от нуля!')
else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
else WriteLn('f(',x,') = ',Ln(2*x+3)*4/(Tan(3*x)*Ln(10)))
End.
Второй вариант: если логарифм по основанию (2x+3) от 4.
Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Основание логарифма должно быть больше нуля!')
else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
else WriteLn('f(',x,') = ',Ln(4)/(Tan(3*x)*Ln(2*x+3)))
End.
- 15.05.2015 19:50
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.