Вопрос по информатике:
Напишите программу на языке Паскаль!!! На экран вводится два пятизначных числа. Найти среднее арифметическое всех четных цифр в наименьшем числе.
- 18.09.2017 22:31
- Информатика
- remove_red_eye 14697
- thumb_up 33
Ответы и объяснения 1
a, b, n: integer;
sr: real;
begin
sr := 0;
n := 0;
read(a, b);
if(a > b) then a := b;
while a > 0 do
begin
if((a mod 10) mod 2 = 0) then begin
sr := sr + a mod 10;
n := n + 1;
end;
a := a div 10;
end;
write(sr / n);
end.
- 19.09.2017 17:40
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.