Вопрос по информатике:
Определите значение целочисленных переменных a и b после выполнения фрагмента программы.
Бейсик Паскаль Алгоритмический
a = 3456
b = (a MOD 100)*100
a = a\100 + b
'\ и MOD – операции, вычисляю-щие результат деления нацело первого аргумента на второй и остаток от деления соответствен-но a:= 3456;
b:= (a mod 100)*100;
a:= a div 100+b;
{div и mod – операции, вычисля-ющие результат деления нацело первого аргумента на второй и остаток от деления соответствен-но} a:= 3456
b:= mod(a, 100)*100
a:= div(a, 100) + b
|div и mod – функции, вычисляющие результат деления нацело первого аргумента на второй и остаток от деления соответственно|
- 09.04.2017 02:01
- Информатика
- remove_red_eye 7425
- thumb_up 42
Ответы и объяснения 1
a,b:integer;
begin
a:= 3456;
b:= (a mod 100)*100;
a:= a div 100+b;
writeln(a);
writeln(b);
end.
a - 5634
b - 5600
- 01.01.1970 00:00
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.