Вопрос по информатике:
Помогите написать программу в Паскале.
Задано натуральное число n (n ≤ 9999). Определить количество цифр числа n^2.
- 07.07.2016 02:03
- Информатика
- remove_red_eye 1538
- thumb_up 30
Ответы и объяснения 1
Var n:longint;
Begin
Write('n = ');ReadLn(n);
n:=n*n;
if frac(Ln(n)/Ln(10)) > 0 then WriteLn(int(Ln(n)/Ln(10))+1)
else WriteLn(Ln(n)/Ln(10))
End.
Второй способ:
Var
n,k:longint;
Begin
Write('n = ');ReadLn(n);
k:=0;
n:=n*n;
While n > 0 do
Begin
k:=k+1;
n:=n div 10
End;
WriteLn(k);
End.
- 08.07.2016 20:03
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.