Вопрос по информатике:
Дано натуральное число n. Найти отношение последней цифры к первой цифре заданного числа.
Помогите написать программу в Паскале.
- 24.02.2018 20:09
- Информатика
- remove_red_eye 6940
- thumb_up 26
Ответы и объяснения 1
n, i, p1, p2: integer;
begin
read(n);
p2 := n mod 10;
while n > 0 do
begin
if(n div 10 <= 0) then p1 := (n mod 10);
n := n div 10;
end;
write(p2 / p1);
end.
- 25.02.2018 03:17
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.