Вопрос по информатике:
ИВТ 99 БАЛЛОВ!!!!
Напишите программу в паскале
Даны два БоЛьШуЩиХ ЧиСЛа. Проверьте, делится ли их произведение на девять.
Формат файла входных данных:
В двух строках входного файла даны два целых неотрицательных числа, по одному в строке. Запись каждого из них состоит из не более чем 106 цифр.
Формат файла выходных данных:
В единственной строке выходного файла выведите "YES", если произведение данных чисел делится на девять, и "NO" в противном случае (без кавычек).
Пример:
72
840
YES
3
5
NO
Ограничение по времени : 3 сек
Ограничение по памяти : 256 Мб
Обычная программа по типу перемножить числа и проверить, кратно ли произведение 9 НЕ ПОДХОДИТ
Пожалуйста, учитывайте ограничения по времени и памяти
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 12.09.2015 03:21
- Информатика
- remove_red_eye 4791
- thumb_up 35
Ответы и объяснения 1
function mod9(f: text): integer;
var
c: char;
rem: integer;
begin
rem := 0;
while not eoln(f) do
begin
read(f, c);
rem := (rem + ord(c) - ord('0')) mod 9;
end;
readln(f);
mod9 := rem;
end;
var
f: text;
a: integer;
begin
assign(f, 'input.txt');
reset(f);
a := mod9(f) * mod9(f);
close(f);
assign(f, 'output.txt');
rewrite(f);
writeln(f, a);
if a mod 9 = 0 then
write(f, 'YES')
else
write(f, 'NO');
close(f);
end.
- 14.09.2015 00:56
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.