Вопрос по информатике:
1. С клавиатуры вводится X и N. Составь алгоритм вычисления X в степени N. Напиши программу на Паскале
- 02.11.2017 08:55
- Информатика
- remove_red_eye 13600
- thumb_up 18
Ответы и объяснения 2
x, n, res : integer;
begin
res := 1;
readln(x);
readln(n);
for var i:=1 to n do res := res * x;
writeln(res);
end.
пишу с телефонв, не уверен, может быть в строке for... надо n-1 а не просто n
- 03.11.2017 08:34
- thumb_up 4
n, i, a: integer;
p: BigInteger;
begin
p := 1;
Writeln('Введите числа');
Write('a=');
Readln(a);
Write('n=');
Readln(n);
for i := 1 To n Do p := p * a;
writeln(p);
end.
- 04.11.2017 18:40
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.