Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 1. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 1. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 1. Пример работы программы: Входные данные:3 11 21 31 Выходные данные:31
- 17.02.2018 13:57
- Информатика
- remove_red_eye 1783
- thumb_up 33
Ответы и объяснения 1
begin
var n := readinteger;
var max := 0;
for var i := 1 to n do
begin
var temp: integer;
read(temp);
if (temp mod 10 = 1) and (temp > max) then
max := temp;
end;
write(max);
end.
- 18.02.2018 14:27
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.