Вопрос по информатике:
Информатика (Pascal): Составить программу для решения следующей задачи: Среди всех положительных трёхзначных чисел найти и выписать на экран те,у которых сумма крайних цифр совпадает с утроенной средней цифрой.
- 08.10.2017 20:03
- Информатика
- remove_red_eye 10936
- thumb_up 38
Ответы и объяснения 2
Begin
For a:= 1 to 9 do
For b:= 0 to 9 do
For c:= 0 to 9 do
if a+c = 3*b then Write(a,b,c,' ')
End.
- 09.10.2017 13:55
- thumb_up 43
// Внимание! Если программа не работает, обновите версию!
begin
for var i:=1 to 9 do
for var j:=0 to 9 do
for var k:=0 to 9 do
if i+k=3*j then Write(i,j,k,' ');
Writeln
end.
Результат
112 125 138 211 224 237 310 323 336 349 422 435 448 521 534 547 620 633 646 659 732 745 758 831 844 857 930 943 956 969
- 01.01.1970 00:00
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.