Вопрос по информатике:
Помогите пж
Напишите программу,которая в последовательности натуральных чисел определяет количество двузначных чисел,кратных 8. Программа получает на вход натуральные числа,количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода,не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: количество двузначных чисел,кратных 8.
- 12.02.2018 10:35
- Информатика
- remove_red_eye 12478
- thumb_up 50
Ответы и объяснения 1
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
Write(ReadSeqIntegerWhile(k->k>0).Where(k->(k in [10..99]) and (k mod 8=0)).Count)
end.
- 13.02.2018 20:40
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.