Вопрос по информатике:
Ниже записана программа. Получив на вход число x , эта программа печатает два числа, a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 0.
var x, a, b : integer;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
a := a + 1;
b := b * (x mod 10);
x := x div 10;
end;
writeln(a); write(b);
end.
- 20.10.2016 19:33
- Информатика
- remove_red_eye 16288
- thumb_up 21
Ответы и объяснения 1
в b - произведение цифр
то есть число x - трехзначное и произведение его цифр=0,
990 - максимальное из трёхзначных, произведение цифр которых=0
ответ 990
- 21.10.2016 05:48
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.