Вопрос по информатике:
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры.
2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры.
3. Написать программу, вычисляющую среднее арифметическое чисел, принадлежащих диапазону [–5; 5], среди пяти, вводимых с клавиатуры
- 12.06.2018 10:23
- Информатика
- remove_red_eye 19605
- thumb_up 27
Ответы и объяснения 1
var a,i,sum:integer;
Begin
sum:=0;
for i:=1 to 5 do
begin;
read(a);
if (a<0) and (a mod 5=0) then
sum:=sum+a;
end;
writeln(sum);
End.
Program z2;
var a,p,i:integer;
Begin
p:=1;
for i:= 1 to 5 do
begin;
read(a);
if (a mod 10=2) or (a mod 10=4) then
p:=p*a;
end;
writeln(p);
End.
- 13.06.2018 15:47
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.