Вопрос по информатике:
Паскаль
Написать программу которая по введенному четырехзначному числу выводит сумму его цифр.
Спасибо.
- 08.02.2016 19:31
- Информатика
- remove_red_eye 14917
- thumb_up 16
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var t:=Abs(ReadInteger('n='));
var s:=0;
while t>0 do begin
s:=s+t mod 10;
t:=t div 10
end;
Writeln('Сумма цифр равна ',s)
end.
Пример
n= 3048
Сумма цифр равна 15
Замечание: число не обязательно должно быть четырехзначным и не обязательно положительным.
- 09.02.2016 19:20
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.