Вопрос по информатике:
Напишите программу сложения, вычитания и умножения двух двоичных чисел. Предложите способ проверки результата: 1011 и 110
- 02.03.2018 07:34
- Информатика
- remove_red_eye 4675
- thumb_up 15
Ответы и объяснения 1
Rn : String[36] = '0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ';
Function DecToN(a : Longint; Raz : Byte) : String;
Begin
If a>Raz-1 then DecToN:=DecToN(a div Raz,Raz)+Rn[(a mod Raz)+1]
else DecToN:=Rn[a+1];
end;
Function NToDec(a : String; Raz : Byte) : Longint;
Begin
If Length(a)>0 then NToDec:=Pos(a[Length(a)],Rn)-1+Raz*NToDec(Copy(a,1,Length(a)-1),Raz)
else NToDec:=0;
end;
Var a,b : String;
Begin
a:='1011'; b:='110';
Writeln('a = ',a,' (bin) = ',NToDec(a,2),' (dec)');
Writeln('b = ',b,' (bin) = ',NToDec(b,2),' (dec)');
Writeln(a+'+'+b+' = ',DecToN(NToDec(a,2)+NToDec(b,2),2),' (bin) ',NToDec(a,2)+NToDec(b,2),' (dec)');
Writeln(a+'-'+b+' = ',DecToN(NToDec(a,2)-NToDec(b,2),2),' (bin) ',NToDec(a,2)-NToDec(b,2),' (dec)');
Writeln(a+'*'+b+' = ',DecToN(NToDec(a,2)*NToDec(b,2),2),' (bin) ',NToDec(a,2)*NToDec(b,2),' (dec)');
end.
- 03.03.2018 02:15
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.