Вопрос по информатике:
На языке программирования Паскаль напишите программу, которая:
1) В последовательности чисел находит количество чисел, кратных 3.
2) В последовательности чисел находит максимальное четное число, оканчивающееся на 4.
- 07.06.2018 16:10
- Информатика
- remove_red_eye 19511
- thumb_up 20
Ответы и объяснения 1
program kr3sum;
var i,s.h:integer;
begin
read(k) //кол чисел
for i:=1 to k do begin
read(h) //число для действий
if h mod 3 = 0 then begin s:=s+1;
end;
writeln(s);
end.
2)
program jeje;
var k,i,m,s,h:integer;
begin m:=0;
read(k);//кол-во чисел
for i:=1 to k do begin
readln(h);
if h mod 10 = 4 then begin s:=h;
if s > m then m:=s
end;
end;
write(m);
end.
- 08.06.2018 15:14
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.