Вопрос по информатике:
Напишите программу на Паскаль,которая в последовательности натуральных чисел определяет максимальное отрицательное число,оканчивающееся на 3.
Программа получает на вход количество чисел в последовательности,а затем сами числа.
Количество чисел не превышает 1000. Введенные числа по абсолютной величине не превышают 30 000.
Программа должна вывести одно число-максимальное отрицательное число,оканчивающееся на 3.
- 18.09.2018 06:24
- Информатика
- remove_red_eye 13266
- thumb_up 26
Ответы и объяснения 1
begin
write('n = ');
readln(n);
max:=-30000;
writeln('Вводите числа:');
for i:=1 to n do
begin
readln(a);
if (abs(a) mod 10=3)and(amax) then max:=a;
end;
if max=-30000 then writeln('Нет чисел, оканчивающихся на 3')
else writeln('max = ',max);
end.
Пример:
n = 5
Вводите числа:
5
618
-703
103
-243
-815max = -243
- 19.09.2018 00:48
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.