Вопрос по информатике:
Составьте программу вычисления значений функции y=1/(x*x-1/(1+x*x)) для x=1,2...10.
- 05.11.2017 00:22
- Информатика
- remove_red_eye 19077
- thumb_up 24
Ответы и объяснения 1
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
Range(1,10).Tabulate(x->1/(x*x-1/(1+x*x))).Println
end.
Результат
(1,2) (2,0.263157894736842) (3,0.112359550561798) (4,0.0627306273062731) (5,0.0400616332819723) (6,0.0277986476333584) (7,0.0204164965291956) (8,0.0156287569127194) (9,0.0123475380213823) (10,0.0100009901970492)
2. Школьное решение
var
x:integer;
begin
for x:=1 to 10 do
Writeln(x,' ',1/(x*x-1/(1+x*x)))
end.
Результат
1 2
2 0.263157894736842
3 0.112359550561798
4 0.0627306273062731
5 0.0400616332819723
6 0.0277986476333584
7 0.0204164965291956
8 0.0156287569127194
9 0.0123475380213823
10 0.0100009901970492
- 06.11.2017 19:01
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.