Вопрос по информатике:
Напишите программу в среде паскаль
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2.
Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 2.
Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, оканчивающееся на 2.
- 06.12.2015 09:16
- Информатика
- remove_red_eye 984
- thumb_up 47
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadlnInteger;
Writeln(ReadSeqInteger(n).Where(i->abs(i) mod 10=2).Max)
end.
Пример
18
-11 12 -4 -35 -32 -16 -23 -22 31 -10 2 -29 47 49 42 47 31 -44
42
- 07.12.2015 04:52
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.